HDU 1372 Knight Moves (BFS)

Knight Moves

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9859    Accepted Submission(s): 5812

Problem Description
A friend of you is doing research on the Traveling Knight Problem (TKP) where you are to find the shortest closed tour of knight moves that visits each square of a given set of n squares on a chessboard exactly once. He thinks that the most difficult part of the problem is determining the smallest number of knight moves between two given squares and that, once you have accomplished this, finding the tour would be easy.
Of course you know that it is vice versa. So you offer him to write a program that solves the "difficult" part.

Your job is to write a program that takes two squares a and b as input and then determines the number of knight moves on a shortest route from a to b.

Input
The input file will contain one or more test cases. Each test case consists of one line containing two squares separated by one space. A square is a string consisting of a letter (a-h) representing the column and a digit (1-8) representing the row on the chessboard.

Output
For each test case, print one line saying "To get from xx to yy takes n knight moves.".

Sample Input
  
  
e2 e4 a1 b2 b2 c3 a1 h8 a1 h7 h8 a1 b1 c3 f6 f6

Sample Output
  
  
To get from e2 to e4 takes 2 knight moves. To get from a1 to b2 takes 4 knight moves. To get from b2 to c3 takes 2 knight moves. To get from a1 to h8 takes 6 knight moves. To get from a1 to h7 takes 5 knight moves. To get from h8 to a1 takes 6 knight moves. To get from b1 to c3 takes 1 knight moves. To get from f6 to f6 takes 0 knight moves.

Source

题解:给你一个棋谱的图吧,然后马步踏棋,日字走法,问你几步能到达终点。所以方向有八个!!!(如图)


AC代码:
#include<stdio.h>
#include<iostream>
#include<cstring>
#include<queue>
using namespace std;
int step;  
int dir[8][2]={{1,-2},{2,-1},{2,1},{1,2},{-1,2},{-2,1},{-2,-1},{-1,-2}};
int map[10][10],ex,ey;  
char s1[5],s2[5];  
struct node  
{  
    int x,y,step;
//	friend bool operator <(node a,node b)
//	{
//		return a.step>a.step;
//	  }  
};  

int bfs()  
{  
    int i;  
    memset(map,0,sizeof(map));  
    node st,ed;  
    st.x = s1[0]-'a';  
    st.y = s1[1]-'1';  
    st.step = 0;  
    ex = s2[0]-'a' ; 
    ey = s2[1]-'1';  
   // priority_queue<node> q;  
    queue<node> q;
    map[st.x][st.y] = 1;  
    q.push(st);  
    
    while(!q.empty())  
    {  
        st = q.front();  
        //st=q.top();
        q.pop();  
        if(st.x == ex && st.y == ey)
		{
			 return st.step;  
		  }     
        for(i = 0; i<8; i++)  
        {  
            ed.x = st.x+dir[i][0];  
            ed.y = st.y+dir[i][1];       
            if (ed.x>=0&&ed.x<8&&ed.y>=0&&ed.y<8&&map[ed.x][ed.y]==0)  
            {  
                ed.step=st.step+1;  
                map[ed.x][ed.y]=1;  
                q.push(ed);  
            }  
        }  
    }  
    return 0;  
}  
  
int main()  
{  
    while(~scanf("%s%s",s1,s2))  
    {  
        printf("To get from %s to %s takes %d knight moves.\n",s1,s2,bfs());  
    }  
    return 0;  
}  


  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值